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 MARKETING ENGINEERING FOR EXCEL      TUTORIAL     VERSION 160917 

 

 

Tutorial 

Getting Started 

 Overview 
Marketing Engineering for Excel (MEXL) is an add-in for Microsoft’s Excel 
spreadsheet software.  MEXL appears as a drop-down menu (labeled 
ME►XL) in the Excel toolbar. 

MEXL is the result of years of research on the theory and practice of 
applying analytics to marketing.  Within the ME►XL menu, you will find a 

variety of analytic tools that bring fact-based analysis to bear on marketing 
decisions. 

The software includes a tutorial for each model for those who want an 
overview of the capabilities within each model.  There are also context-
sensitive Help files integrated within each model. 

MEXL provides a set of analysis tools that can be used as teaching aids in 

conjunction with any of our textbooks.  These textbooks may be purchased 
directly at our website, www.decisionpro.biz. 

System Requirements  
MEXL has been developed for Microsoft’s Windows Operating System.  
Because it is an Excel add-in, you will need to have installed Microsoft’s 
Excel (Windows version) product to download and install Marketing 
Engineering for Excel on your computer. 

DecisionPro supports MEXL in the following environments: 

 Windows 7, Windows 8, or Windows 10 operating systems. 

 Microsoft Office/Excel versions 2007, 2010, 2013, or 2016. 

(Mac users should consult the DecisionPro website for alternative options 
for accessing the software.) 

Software Download 
There are two download options for the Marketing Engineering for Excel 
add-in. One version is compatible with the 32-bit version of Excel and the 
other is compatible with the 64-bit version of Excel. Installing the 
incorrect version will result in the add-in not appearing in Excel. To 
determine which version of Excel you have: 

 Prior to Office 2010, all Excel versions were 32-bit. 

 Office 2010, 2013, or 2016 may be either 32-bit or 64-bit. To 
determine if you have the 32-bit or 64-bit version of Office, open 
Excel and go to File -> Account in Office 2013/16 or File -> Help in 
Office 2010. Under the About Microsoft Excel heading will be your 
Excel version number followed by either 32-bit or 64-bit. 

Software Installation 
The file downloaded from www.decisionpro.biz is a compressed zip file 
containing the software installation file and the Getting Started Guide. 
Expand the zip file before running the installation file (right click on the zip 

file and select “Extract All...”). After expanding, double click the installation 

http://www.decisionpro.biz/
http://www.decisionpro.biz/
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file (e.g., MEXL_V2-0_EDU_130530.msi).  (Be sure to uninstall any 
previous versions of MEXL before installing a new version; see the section 
on software removal to do so.) 

 

Depending on the settings of your particular system, you may get a 

security warning, as shown in the following dialog box. If such a warning 
appears, click on the Run button.  

 

 

If installing with Windows 8, you may get the security warning shown 
below.  If you click “OK” the installation will terminate.  You must click 

“More info”. 

Clicking “More info” will show the screen below, where you should click 
“Run anyway” 

 

This guide has been developed for installation using Windows XP and Office 2003.  
Users installing with later versions of Windows or Office may see subtle differences in 
the installation prompts, but the overall flow will remain the same. 

Should you encounter any difficulty during installation of Marketing Engineering for 
Excel, please visit www.decisionpro.biz and review the FAQs located there.  

If you are unable to resolve an installation problem, please email us at 
support@decisionpro.biz. 

http://www.decisionpro.biz/
mailto:support@decisionpro.biz


GETTING STARTED TUTORIAL – V160917  3/15 

 

 

Note: If you have User Account Control (UAC) enabled, you may also get a 

prompt from UAC asking for permission to continue the installation. 
 

 

When the initial MEXL installation dialog box appears, click Next. 

 

 

You will be prompted to choose the folder in which you want to install the 
software. Change the default folder location if desired.  It is best to install 
MEXL on a local drive rather than a network drive.  Click Next when ready. 

 

If you do not have Microsoft’s .Net Framework 4.0 installed before 
installing MEXL, the MEXL installation will terminate and direct you to install 

the .Net Framework before continuing.  If you require assistance in 
obtaining the .Net software, please visit the MEXL FAQ page on 
www.decisionpro.biz.  

 

http://www.decisionpro.biz/
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MEXL is distributed with several optional data files that provide additional 
analytic spreadsheets you may find useful. The default installation 
directory for these optional files is My Marketing Engineering under My 
Documents.   
 
To accept this location, click Next.  To choose a different directory, 

overtype the file name displayed.   

 

 

 

A dialog box will appear and ask you to confirm the software installation.  
Click Next to install, or click Cancel to stop the installation. 
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The dialog box below will appear with a bar showing installation progress.  
If you have User Account Control enabled, you may also get a pop-up from 
Windows asking you to allow the installtion. 

 

 

When the MEXL software installation is complete, the following dialog box 

appears.  Click Close to close the dialog box.  
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When MEXL installation is fully complete, you may begin using MEXL. Start 
Excel and click on the ME►XL drop-down menu in the Excel toolbar (under 

Add Ins tab in Excel 2007 and later). 

Software Removal 
Should you need to remove MEXL, you may do so from the Windows 
Control Panel, using the Add/Remove Programs function.  Note that before 

installing a newer version of MEXL, you will need to remove the previous 
version using this process. 

From the Windows Control Panel  Add/Remove function, choose 

Marketing Engineering for Excel. If you have User Account Control enabled, 
you must confirm the removal of the software; click Yes or No as 
appropriate. 

 

 

To preserve any files you may have created within the My Marketing 
Engineering directory, this directory is not removed during the uninstall 
process.  If you no longer require this directory or files, you may remove 
them manually. 
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Starting MEXL  

MEXL will load as an Excel add-in each time you start Excel and a new menu 
item (ME►XL) will be created. The location of the menu item will depend 

on your version of Excel. 

 

MEXL using Excel XP or 2003 

After you open Excel, the ME►XL menu appears in the Excel toolbar.  
When you click on the ME►XL menu, the following menu appears: 

 

In the sections that follow, you will find descriptions of the elements within 
the individual software models. 
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MEXL using Excel 2007, 2010, 2013, or 2016 

With recent versions of Excel, the ME►XL menu is accessed from the Add-

Ins tab, as shown in the sequence below.   

 

 

 

 

 

 

 

 

 

 

 

 

 

When you click on the drop down arrow next to the ME►XL menu, the 

following menu appears: 

 

 

In the sections that follow, you will find descriptions of the elements within 
the individual software models. 

 

Activating MEXL
  

Most copies of MEXL will be fully functional for a brief trial period before 
requiring activation.  You can see how many days remain on your license 
by clicking the About Marketing Engineering for Excel item in the MEXL 

toolbar item. If the software is not activated within the trial period, it will 
revert to a demo mode and the MEXL analysis option will be disabled. 
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Obtaining a Software License 

There are different options for obtaining a software license depending on 

your university (#2 is most common): 

1. If your university has provided you with a Software License ID and 
Software Password, you may use that to activate the software. 

2. If you have subscribed to the student materials on the DecisionPro 
website, you may request a Software License ID and Password on 
the website at http://www.decisionpro.biz/students/current-

students/access-software: 

 

3. If your university has provided the software download but not 
access to the DecisionPro website, you may click the “Buy Now” 
button to purchase a license from within the software. 

   

http://www.decisionpro.biz/students/current-students/access-software
http://www.decisionpro.biz/students/current-students/access-software
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Activating Your Software (requires an internet connection) 

There are two methods to activate your software: 

1. Activate Online 

The first (and preferred) method is to use the Activate Online 
option. The Activate Online option will automatically connect to our 
license server to activate the software using your License ID and 
Password. To start the process, click the Activate Online button 
and a new window will open where you enter your License ID, 
Password, and Email Address: 

 
 
After entering your information, click Activate. You will receive an 
“Action Complete” message if the activation is successful. The 
About Marketing Engineering for Excel window should now show 
that your license status is Active.  

 

 
 
If the activation fails or you find your software is not active even 

after receiving an “Action Complete” message, it is usually an 
indication that a firewall or other computer/network security is 
preventing our activation server from communicating with your 
computer to complete the activation. In this case, proceed to the 

Activate Manually option. 
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2. Activate Manually 
The second method (if the online activation does not work) is the 
Activate Manually option. The manual activation process requires 
copying and pasting data between the software and our license 

server to complete the activation. Clicking the Activate Manually 
button will bring up the following window: 
 
 

 
 
Enter your License ID and Password and click Generate Request. 
The Activation Request data section will fill with the necessary 
information identifying your software and computer: 
 

 
Click the Copy button and then the Open Activation Web 
Page button.  A new webpage will open in your browser. Follow 

the online instructions to paste the Activation Request data into the 
website: 
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Clicking the Submit button will provide a Response code that must 
then be copied and pasted back into to the software. 
 

 
 
Paste the Activation Code into the software and click Activate to 
complete the process. 
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Tutorials 

MEXL is distributed with tutorials for each individual model.  These tutorials 
can be found in the submenu for each model, as illustrated below. 

 

 
 

Users new to Marketing Engineering will find the tutorials provide valuable 
explanations of the models, data requirements, how data are used, and 
how to interpret the model output.  

Help Files 

Within each MEXL model, you will find context-sensitive Help files.  To use 
the integrated Help capability, click on the icon shown in the top-right 

corner of each MEXL dialog box. 
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After clicking , move your mouse to the area of the dialog box with 

which you would like help, and click it.  A Help dialog box will open for the 
specific area and also show the complete Help index. 

The complete Help index also is available as a selection from the ME►XL 

menu.  

Using MEXL with Excel 

The MEXL software is an Excel add-in which allows you to use the full range 

of Excel capabilities along with your MEXL tools. While a full description of 
Excel capabilities is beyond the scope of this guide, here are a few 

suggestions to enhance your use of MEXL. 

 All MEXL output is delivered in an Excel workbook, using standard 
Excel objects such as cells, charts and graphs.  Right-clicking on a 
label, chart or line will allow you to format that item as you would 
in any Excel workbook.  This is useful when incorporating MEXL 
output in a presentation. 

 MEXL outputs all the data in a given study, some of which might be 

superfluous in your final analysis.  You can select and delete any 
output that does add value to the analysis to reduce the “chart 
clutter”. 

 Using the right mouse button you can easily change the color or 

weight of lines to draw attention to items that are critical in your 
analysis. 

The Help menu item in the Excel toolbar will offer you additional resources 

to allow you to customize your MEXL output. 
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Additional Resources 

The MEXL software implements tools and techniques explained in two books 
made available through DecisionPro.   

 

Principles of Marketing Engineering, 2nd Edition 

(2013, Gary L. Lilien, Arvind Rangaswamy, Arnaud De Bruyn) DecisionPro, 

Inc., State College, PA.  

263 pages 

This book provides a non-technical overview of the principles, benefits, and 
applications of Marketing Engineering for practitioners who need to apply 
the tools today and students who will use them tomorrow. 

 

 

Marketing Engineering, Revised Second Edition 

(2004, Gary L. Lilien, Arvind Rangaswamy) Trafford Press: Vancouver BC. 

518 pages  

A more technical and complete version of the Principles book, aimed at the 
reader who wants to know the inner workings of Marketing Engineering. 

 

These books may be purchased through our website, www.decisionpro.biz.   

Also on our website, registered users will find Technical Appendices that 
further explain the analytics used by each model. 
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